Tienes problemas al actualizar los repositorios?

UbuntuSi cuando ejecutas en Ubuntu

sudo aptitude update

obtienes esta respuesta

W: Error de GPG: http://ppa.launchpad.net intrepid Release Las firmas siguientes no se pudieron verificar porque su llave pública no está disponible: NO_PUBKEY DBF1CA1622460E60

W: Tal vez quiera ejecutar ‘apt-get update’ para corregir estos problemas

Se debe a un bug en Ubuntu, que es fácilmente resolvible, siguiendo estos pasos

  1. Descarga el script launchpad-update
  2. Dale permiso de ejecución
    chmod +x  ./launchpad-update
  3. Ejecutar el script con permisos de root
    sudo ./launchpad-update intrepid

Nota que agregué mi distro al final, en este caso Intrepid, si usas Hardy o Gutsy, recuerda cambiar ese parámetro.

Recuerda:
Si te funcionó (o no), deja tu comentario, es la única forma de saber que esto le es útil a otras personas, como espero que lo sea..

0 comments Add yours
  1. Eso sólo sucede si tienes en tu lista de repositorios un origen con una clave pública que no puede ser verificada. Esos repositorios por lo general se agregan cuando queremos añadir software que no vienen con la distribución, por estar en evaluación o porque al distribuidor no le interesa, como es el caso de AWN.

    Particularmente, prefiero mantener mi Sistema Operativo con los repositorios que mantiene el fabricante. De esa manera me ahorro muchos problemas.

    El script debería funcionar porque corrige el problema de la clave pública que no ha sido validada, agregándola a “apt”.

  2. Exactamente. Nunca mejor dicho.

    Últimamente he estado haciendo lo mismo, por rapidez al actualizar los repositorios y por sanidad del sistema. Antes solía incluír cuanto repositorio no-oficial conseguía, pero ahora también prefiero un sistema más ligero y no tan cargado de aplicaciones de terceros.

    El bug impide actualizar precisamente las claves públicas de repositorios no oficiales, pero ya fue corregido en la versión de prueba de Ubuntu Jaunty..

  3. Bueno, yo si utilizo repositorios no oficiales, y se debe a que no siempre existen en los repositorios los programas en su versión más reciente (estable, claro está) y un ejemplo es el SMPlayer, un front-end del MPlayer hecho en qt. En los repositorios de oficiales sigue estando la versión que funciona desde hardy, y la versión estable oficial ya tiene aproximadamente 4 o 5 versiones más adelante.

    Igual es el caso para muchos juegos, que se actualizan más rápidamente en getdeb que en los repositorios oficiales.

    De todas formas muchas gracias por el dato, lo tendré en cuenta para actualizar mis repos.

  4. Gracias por el dato pero no sé si en verdad me funciona, yo creo que no, me da el siguiente mensaje:
    Release: hardy
    Please Wait…
    cat: keyss: No existe el fichero ó directorio
    rm: no se puede borrar «keyss»: No existe el fichero ó directorio

  5. Tragalibros: No lo he probado en Hardy.. Pero lo que te falló es el ultimo paso, asi que la actualizacion debe haberse hecho sin problemas..

    Joan: Me alegra que te sea de utilidad..

    X3MBoy: Yo tambien suelo agregar a getdeb como repositorio, pero se me hace inestable el sistema con algunas aplicaciones..

  6. Estimado…
    Lamento comunicarte que el link que brindas al scrpt del launchpad-update, no funciona…, o quizá dicho scrpt, no está bien señalizado y mira que lo busqué…., me leí toda la página todos los artículos y NADA…
    Por favor podrías enviarme un link que funcione a mi correo electrónico.
    Te agradezco infiniamente.-

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *