Instalando el sonido en Ubuntu 7.10 Gutsy Gibbon

Desde que actualicé mi Ubuntu 7.04 al nuevo Ubuntu 7.10 Gutsy Gibbon, había perdido los drivers de sonido de la tarjeta integrada en mi Laptop DELL 1721, para la cual Intel ni DELL tienen aún ningún driver nativo disponible. Así que no nos queda otra que echarle mano a los drivers ALSA (Advanced Linux Sound Architecture). Para ello, seguí los siguientes pasos:

  1.    Instalé los módulos backports
    sudo apt-get install linux-backports-modules-generic
  2. Instalé paquetes necesarios
    sudo apt-get install libc6-dev
    sudo apt-get install patch
  3. Descargué la última versión de los Drivers ALSA
    wget ftp://ftp.alsa-project.org/pub/driver/alsa-driver-1.0.15.tar.bz2
  4. Descomprimí e instalé los drivers
    tar xvpjf alsa-driver-1.0.15.tar.bz2
    cd alsa-driver-1.0.15
    ./configure --with-cards=hda-intel,emu10k1
    make
    sudo make install
  5. Reinicié y voilá.. Sonido funcionando!
0 comments Add yours
  1. Hola que tal me tope con esta pagina buscando la manera de tener audio en mi maquina.. Instale el ubuntu y escucho el sonido inicial, pero no puedo escuachar musica ademas los puertos USB no funcionan bien. Tengo en otra particion a windows y ahi todo esta perfecto. No se si me puedas hechar la mano. Encontre mi trajeta de sonido en el alsa project, es una AD1982b de analog devices..
    Mi maquina es una lap-top toshiba m45-s265.

  2. paco, mira a ver si puedes instalar automatix

    me parece que tu tarjeta de sonido esta trabajando perfectamente, puesto que dices que puedes escuchar el sonido inicial,

    entonces lo que te esta pasando es que te faltan los codecs para reproducir algunos archivos de sonido como el mp3

    instala automatix y tu problema quedara resuelto…

    aunque me parece que so instalas xmms tambien se te puede resolver el problema.

    prueba a ver si puedes reproducir tu musica con XMMS primero:

    aqui las instrucciones cortas para instalarlo desde apt.

    ——
    sudo aptitude install xmms
    ——

    y con ese comando tendras todo resuelto
    suerte

  3. saludos… sabes lo unico que me falta para dejar a windows vista es el sonido??
    en vista funciona bien el sonido pero no en ubuntu…. tengo la version 7.10 y compiz
    funciona excelente tanto asi que no tuve que configurar nada gracias a que mi tarjeta
    es una Intel 945 GM Espress y HD de Sonido 6.0 M e gustaria mucho que puedas darme
    una mano en esto?? Auque hay unos programas o no se como llamarlos que hablan de
    punto de montaje?? y en my escritorio de ubuntu aparece el disco duro de archivos
    y de volumen la cual es de toshiba… mi pregunta ahora es porque?? ya que le doy boton derecho
    y aparece una line que me dice si quiero desmontar volumen?? no me he atrevido a
    hacerlo xq la otra vez tuve problemas….gracias te agradezco respuesta ese es mi coreeo
    si tienes alguna sugerencia??

  4. Hola yo tengo una lap dell 1721 y le trate de instalar ubuntu 7.10 pero no me quedo por lo que veo en tu post tu se lo has intalado con exito me podrias decir mas o menos que version instalaste o como le hiciste ya que de entrada a la mia no me habia reconicido la targeta de video es la ATI 1270 y tambien tuve problemas con el sonido bueno si es que me puedes ayudar ahi esta mi email muchas gracias

  5. Hola RM619, fíjate que por ciertos problemas de configuración tuve que formatear e instalar ubuntu recientemente, por lo cual decidi hacerme un wiki para ir poniendo todo lo que voy haciendo para tener Gutsy funcionando en nuestra laptop, te recomiendo lo visites y lo actualices si quieres..

    La dirección es http://wiki.superubuntu.com/

    Espero te sea de utilidad

  6. Hola muchas gracias voy a leerlo con detenimiento y espero hoy en la noche instalarlo como se debe ya despues te cuento lo que valla pasando y si puedo aportar algo interesanto al wiki lo hare .

    gracias y saludos 😀

  7. ahhh,
    muchas gracias por este pequeño «totorial».
    despues de probar varias distros, me decidí por ubuntu. y…. sorpresaaa, tampoco me iba el sonido.
    Pero en un plis, claro está! Con tu ayuda.
    Solucionado.
    Ahora a configurar internet con el modem de vodafone, y estaría en las nubes.

    Muchas gracias.

  8. Hola Óscar, me alegra poder ayudar a otras personas y contribuír a que cada día más gente descubra el software libre y linux en particular. Luego que cada quien use lo que sirva, pero raramente alguien que descubra la potencia de linux y la libertad del software decide seguir usando aplicaciones propietarias. Es mi granito de arena a una comunidad que tantas cosas nos ha aportado a los usuarios finales.

    Para configurar tu módem, visita http://www.guia-ubuntu.org

  9. hola, gracias por el aporte, tengo una duda, como instalo automatix? ya que instale el que el amigo decia, de xmms y si se oye algo de sonido, pero se ye como con distorcion como si estuviera lloviendo solo asi puedo definirlo
    gracias a todos

  10. hola yo me he topado con ese problema, se oye como un sonido como si estuviera lloviendo no se que podra ser si alguien me puede ayudar con el xmms ya probe no se talves el automatix que dice por ahi un amigo, pero estoy bastante confundida
    hgracias

  11. Hola Luna, estas usando Gutsy o Hardy?

    En hardy puede solucionarse (temporalmente) matando el proceso ‘ pulseaudio’ de la siguiente forma:

    killall pulseaudio

    Esto sucede debido a que las aplicaciones no estan optimizadas o configuradas para enviar su salida de audio a pulseaudio en vez del tipico ALSA o OSD.

    Cuentanos..

  12. hola, gracias por contestar
    no no se cual, tengo creo que es gutsy gibbon pero no estoy segura
    lo que me dejaste no me funciona me dice:
    pulseaudio:ningun proceso eliminado

    otra cosita, el sonido aca no afecta windows verdad? que ya me esta empezando a dar problema la particion de windows tambien =S
    ayuda
    gracias!!

  13. Luna: No tienes pulseaudio instalado por lo que asumo estas usando Ubuntu Gutsy.

    Te recomiendo que uses Audacious en vez de XMMS.

    sudo aptitude install audacious audacious-plugins-*

    Prueba y me avisas..

  14. hola, perdon por tanta lata, lo probe y todavia nada instale antes el xmms y tampoco, he probado varias cosas de internet y mas o menos lo que me funciono fue lo de alsmixer algo asi
    tengo sonido pero sioempre se oye un nos eun ruido de fondo
    que raro
    gracias

  15. hola amigo, disculpa pero lo probe y nada!! estoy muy triste porque solo por eso tengo que seguir usando windows por el sonido,
    que mas podria ser?
    gracias

  16. Laura: permiteme entender algo, tienes sonido o no?

    No desesperes, de alguna forma resolvemos, volver a windows es peor q estar sin sonido, jejejeje..

    Estas cosas pasan en Linux, pero se debe a que los fabricantes hacen los drivers para windows y se olvidan que Linux existe, por tanto hay que ingeniarselas para hacer que esto funcione, eso si, cada vez es menos frecuente..

  17. Hola, tengo instalado tambien ubuntu 7.10 y sin sonido, he probado a seguir los pasos q indicas, pero cuando hago:
    ./configure –with-cards=hda-intel,emu10k1

    me aparece un error:
    checking for which soundcards to compile driver for… configure: error: Unknown soundcard emul0k1

    supongo que será porque tengo que especificar una tarjeta distinta, pero no sé. Estoy un poco perdida!!
    Sé que es un post bastante antiguo, espero tener suerte y que haya respuesta 🙂

  18. Hola Noe,

    Eso te pasa porque no tienes tarjeta de sonido integrada intel, sino probablemente de otra marca..

    Te recomiendo detectes tu tarjeta de sonido y luego busques en Ubuntuforums.org, casi siempre hay alguien que ya solucionó tu problema..

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *